E-Commerce storefronts not loading or loading very slow
Incident Report for Mopro
Resolved
This incident has been resolved.
Posted Jun 26, 2020 - 14:10 PDT
Monitoring
Our team has released a fix and we are currently monitoring it.
Posted Jun 26, 2020 - 13:06 PDT
Identified
We have identified the issue and are urgently working on the fix.
Posted Jun 26, 2020 - 12:50 PDT
This incident affected: Mopro (Digital Command Center, Websites).